Bug of keyboard key...
 
Notifications
Clear all

[Solved] Bug of keyboard keys involved in Elephant

6 Posts
2 Users
0 Reactions
306 Views
(@aleksis7)
Active Member
Joined: 1 year ago
Posts: 4
Topic starter  

Hello, I like this program. But there is one annoying ?bug.

there is a frequent glitch - when typing text on the keyboard, the keys used for the elephant toggle dial for midi then start to fail when typing, and so on "lewdness".
even when the keyboard layout is switched to another language.

to fix - then you need to close the elephant process in the task manager. ?or use keyboard shortcuts with modifiers - but it's not convenient.

here is a picture with my settings (I use dial only for midi)

2

I also would like a checkmark to appear in the elephant settings so that the dial option when starting the preset is enabled by default (as in picture 2)

1

   
Quote
SaveTheHuman5
(@savethehuman5)
Noble Member Admin
Joined: 7 years ago
Posts: 994
 

Hello
So you said....... if  you use the keyboard to type for some long time, then the hotkeys used on elephant  for switch to MIDI values, not work nore and you have to restart the program?
Please confirm.

Need to know, al the info about your Windows version, and OS config, as language and hardware used.

This post was modified 1 year ago by SaveTheHuman5

About: https://savethehuman5.com/about/
Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


   
ReplyQuote
(@aleksis7)
Active Member
Joined: 1 year ago
Posts: 4
Topic starter  

Thank you for quick response!

I may have put it wrong - Elephant is just fine - the hotkeys work as they should. But now it becomes impossible to print with these keys - they either do not work, or other glitches appear. When you delete the Elephant process from the task manager, then everything is fine. but then Elefant himself does not work anymore. this is such a vicious circle.

and this bug is shown in 80% from 100 possible. I tried to experiment to understand why sometimes everything works fine, but I couldn't.

in principle, it is clear that there may be a conflict with other applications - but in this case it turns out that there is a conflict with all applications where you need to print using the keys assigned in Elephant

my system
Windows 10 22H2 education 19045.2604
Windows Feature Experience Pack 120.2212.4190.0
Intel(R) Core(TM) i7-8700K CPU
32gb memory
SSD 
language English and Russian


   
ReplyQuote
(@aleksis7)
Active Member
Joined: 1 year ago
Posts: 4
Topic starter  

I turned on Sherlock Holmes mode and spent another hour on research and found the culprit - it was the program in the tray Qtranslate, which conflicts with Elephant.
and exactly in the highlighted text translation mode.
So for now the solution is to temporarily disable its functions while I am typing.

I'm glad I found the problem and that I saved you the time of searching for the cause

Cheers!))


   
ReplyQuote
(@aleksis7)
Active Member
Joined: 1 year ago
Posts: 4
Topic starter  

Posted by: @aleksis7

I also would like a checkmark to appear in the elephant settings so that the dial option when starting the preset is enabled by default (as in picture 2)

1

It would be great if you find time in the future to make a checkbox in the settings to run in midi mode with the dial selector already enabled. Thank you!

 


   
ReplyQuote
SaveTheHuman5
(@savethehuman5)
Noble Member Admin
Joined: 7 years ago
Posts: 994
 

I mark this as fixed, not is a problem from Elephant and nobody report a problem like this.
Thanks for the update.

About: https://savethehuman5.com/about/
Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


   
ReplyQuote
Share: