Something is making...
 
Notifications
Clear all

Something is making Chameleon hide


sevenoneone
(@sevenoneone)
Active Member Registered
Joined: 4 months ago
Posts: 9
Topic starter  

Happy New Year, and thank you @SaveTheHuman5 for making Chameleon!!! It's genius.

I have an issue I can't figure out, something in my MIDI setup.

I like the Hide button, it's super useful. But every time I switch to a different track in Cubase, Chameleon hides. 

Chameleon (tablet) - rtpMIDI - (desktop) Bome MT Pro - Cubase. There are also 2 hardware controllers.

I tried setting the "Hide" button MIDI settings to channel 0, or to an unused channel, or changing the other MIDI parameters of the Hide button, but it still does the same thing.

Any advice?

 


Quote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

As a first test.
Can disconnect MIDI out in cubase and confirm if problem dissapear?
With this simple test we can know is MIDI issue, what for sure......should be!

Second test, if delete Hide button of your template, problem dissapear?

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote
sevenoneone
(@sevenoneone)
Active Member Registered
Joined: 4 months ago
Posts: 9
Topic starter  

Thankful for your help @SaveTheHuman5 !

Test 1) Disconnect Cubase MIDI out, problem disappears.

Test 2) Connect Cubase MIDI out, delete Hide button, problem appears.

Test 3) After Test 2, delete all objects from template, problem still appears.

I think this is part of the cause:

I use MIDI Fighter Twister - Bome - Cubase

Only one instance of Bome running (same instance as above)

If I switch tracks in Cubase, something with MIDI channel 1 address 0 makes Chameleon hide.

MIDI Fighter Twister uses MIDI channel 1 address 0 for one of its knobs.

 

 

 

 

 


ReplyQuote
sevenoneone
(@sevenoneone)
Active Member Registered
Joined: 4 months ago
Posts: 9
Topic starter  

Hello again @SaveTheHuman5 

I think I need to learn more about using Bome, I probably have a setting wrong.

For now, I made a filter in Bome to swallow MIDI Channel 1 address 0, so Bome does not send it out to Chameleon

No more hiding problem! Thank you for the clues!!! And I'm sorry to bother you.


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

Right now you have a workaround, that is good, i take a look on this soon, sound like a bug.

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote
sevenoneone
(@sevenoneone)
Active Member Registered
Joined: 4 months ago
Posts: 9
Topic starter  

I'm learning how to use Chameleon better, and wondering:

Can I control hiding and unhiding Chameleon using MIDI? 

I would love to assign it to a hardware button!

Or, maybe if the orange "unhide" arrow could be moved somewhere else, like bottom right of screen?


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

Yes you can, create a page button and make work as a button can hidden, setup the desired MIDI value to that button and you can achieve what you want to do.

https://savethehuman5.com/chameleon-user-guide/#buttons

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote
sevenoneone
(@sevenoneone)
Active Member Registered
Joined: 4 months ago
Posts: 9
Topic starter  

Hiding via MIDI works!!! Awesome, thank you.

Is there a way to do this?

Press button, Chameleon hides. Press same button again, Chameleon re-appears


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

The feature is already available trough orange button on top when is hidden.

Not the same button but achieve the same result in a usable way.

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote