Triggering Scrub fr...
 
Notifications
Clear all

[Solved] Triggering Scrub from ANYTHING when using Macie Jog Wheel in DAW


Daniel Kessler
(@kyserkess)
Active Member Registered
Joined: 1 month ago
Posts: 6
Topic starter  

Spent the last five hours trying to trigger the scrub function of the job wheel in my daw. It worked once for a second. I don't want to use my Middle mouse btn because it already has an important use. I was trying to use X-mouse to assign the XTRA btn. There's no documentation on how to do this. I have a Kensington Expert track ball mouse. There are four btns. I have been trying to assign the 4th btn to ANYTHING that Elephant can use to trigger the scrub feature. I am exhausted. I know it is designed to work and I wanted to ask here before I give up. I tried to use the hotkeys to trigger the midi but there's no documentation on that either, so I don't know what its supposed to do. Really simple; I want to press and hold a mouse btn to trigger the scrub function on the jogwheel. 

 

I am using Cubase, with macie control. It works fine as a jog wheel. I am trying to be able to switch into scrub. Windows 10. 


Quote
Topic Tags
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

Hello, there is not hotkey to enable or disable JOG mode, you can assign by mouse buttons.

https://savethehuman5.com/elephant-user-guide/#mcu-mode

The documentation, show how setup Middle Button, but example is the same for xtra1 and xtra2 button.

Example with EXTRA BUTTON 1   >   MIDI BT   BT1   SCRUB

For know what are the xtra buttons of your trackball, click the buttons and you see XTRA 1  and 2 text will be highlighted in elephant config panel.
If that not happen, then you need check if your buttons are programable and how, check vendor driver and utility.

There is no documentation about xtra buttons, because that depend of the mouse and is customizable if mouse is programable.

I test again before reply to you, using my Cougar mouse 700M,  test on Ableton, Reason and Studio One DAWS, all is working ok.

I now own Cubase, but I think all the trouble you have is need program correctly your trackball, is support send xtra 1 and xtra 2 mouse buttons.
For sure no idea if your trackball support xtra buttons events, I take a faster look and only see can assign hotkeys and and some custom actions.
https://www.kensington.com/en-au/software/trackballworks-customization-software/

When you press all that buttons in your mouse, xtra 1 and 2 text is  highlighted in some moment in the elephant software config panel?
If not your trackball not is sending xtra buttons mouse events.

Finally after config, close config menu in order to operate with elephant.

This post was modified 1 month ago by SaveTheHuman5

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote
Daniel Kessler
(@kyserkess)
Active Member Registered
Joined: 1 month ago
Posts: 6
Topic starter  

@savethehuman5 I appreciate your quick reply. Elephant does read my xtra key. It works the first time I try it, but then it stays stuck in scrub. I have to fidget with the dial a bunch before it goes back to jog. Then I can't get it go to back to scrub. Something isn't right. It can work, but there's some glitch. 


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

I have here multiple muse form different brands, and cant reproduce your problem.
Had a chance to test with other mouse.............I know for you not is a option change your appreciated trackball, but just for confirm. 

Some questions:
With middle mouse button work ok? Just to confirm.

If you click the middle button on your trackball,  then the text middle button is highlighted in the control panel and when you stop click back to normal the text?

With extra buttons, when you press text is highlighted on the config panel? When stop click that extra button, remain highlighted?

Apologize lot of questions, your words are my eyes.

This post was modified 1 month ago 3 times by SaveTheHuman5

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote
Daniel Kessler
(@kyserkess)
Active Member Registered
Joined: 1 month ago
Posts: 6
Topic starter  

@savethehuman5 yes the middle BTN lights up when I press the middle and the Xtra BTN lights up when I press the fourth BTN. I configured it correctly. Sometimes, neither light up and I have to restart elephant. Elephant seems to have caused some problems with my license manager as well. 

I will just use it as a jogwhell. The scrub function doesn't work. When it did work, it wouldn't return to jogwheel mode. The application is very finiky. I keep having to restart it before it's recognized.


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

Ok., thanks for the report, I try to pickup in the next weeks cubase and do some test to see what can improve.

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote
Daniel Kessler
(@kyserkess)
Active Member Registered
Joined: 1 month ago
Posts: 6
Topic starter  

if you want to remote connect, you're welcome to try. I am just using it as a jogwheel. I used a hot key for my mouse to scrub. 


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

Thanks for your offer, in this case remote session wont help.
Need reproduce here the error in order to test.

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

I test, with Cubase  and have 0 problem. 
I upload a video soon.

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

Ok is very later here and I feel asleep lol but I create a video.
I think you missed what I explain on the video.
If yes, hen will be solved, if not, then the problem you have in your computer is isolated t your setup, please take a look.
For sure my native language is spanish not english, so apologize the accent and the mistakes related to language.

This post was modified 1 month ago by SaveTheHuman5

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote
Daniel Kessler
(@kyserkess)
Active Member Registered
Joined: 1 month ago
Posts: 6
Topic starter  

@savethehuman5 I appreciate you making the video to test this and demonstrate it. I am not having the same experience. The jogwheel usually does not work and the xtra button for scrub does not work. 


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

Maybe this is related to the trackball you use. I cant provide a solution for a problem cant be reproduced here in order to be debugged.

This post was modified 4 weeks ago by SaveTheHuman5

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote
Daniel Kessler
(@kyserkess)
Active Member Registered
Joined: 1 month ago
Posts: 6
Topic starter  

anyway, i love the jogwheel! Thanks for your video. I still need to refer to it sometimes. 

 


ReplyQuote