Holes not working w...
 
Notifications
Clear all

Holes not working with Reaper


Simon Janssen
(@simonjanssen)
New Member Registered
Joined: 4 months ago
Posts: 4
Topic starter  

I use my touchscreen for the mixer in Reaper. I planned on using Chameleon on the rest of the screen with cutting a hole in it for the Reaper mixer.

Anyway it doesn't work. While I perfectly see the mixer, it doesn't recognize touch input anymore. However it reacts to the mouse, but not to touch input. 

 

Anyone else experienced this?

Cheers!


Quote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

Hello Simon,
Please go to Chameleon config, and uncheck: Disable Legacy Touch Behaviour, test now, the touch trough holes.
Please confirm if the option remain unchecked after close and open again Chameleon.

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote
Simon Janssen
(@simonjanssen)
New Member Registered
Joined: 4 months ago
Posts: 4
Topic starter  

Hi savethehuman5,

thanks, that worked perfectly. But no, it doesn't save these settings when closing and reopening.


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

Ok, great to know that works.
Checking now what cause the problem not save the config.

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

Problem fixed, download the latest version 1.3
https://savethehuman5.com/chameleon-user-guide/#getting-started-2

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote
sevenoneone
(@sevenoneone)
Active Member Registered
Joined: 4 months ago
Posts: 9
 

I'm learning to use holes, and I have a similar question. I use Cubase, and multiple monitors.

Only one monitor is touchscreen, with Chameleon and a hole for touching VST instruments and plugins.

If I uncheck "Disable Legacy Touch Behaviour", I can touch items in the hole. But the cursor jumps to the place I touched the touchscreen. So I have to move the mouse back to original location, every time I touch Chameleon.

If I check "Disable Legacy Touch Behaviour", I can not touch items in the hole.

Is there a way I can use the hole with touch, and also have the cursor not jump around?

I would love to have both features!

 

 

 

 

 


ReplyQuote
Simon Janssen
(@simonjanssen)
New Member Registered
Joined: 4 months ago
Posts: 4
Topic starter  

@sevenoneone do you have Panda installed? 


ReplyQuote
sevenoneone
(@sevenoneone)
Active Member Registered
Joined: 4 months ago
Posts: 9
 

@simonjanssen no I don't have Panda installed. I thought in the Chameleon instructions it said not to install it. Maybe I'll try haha!


ReplyQuote
sevenoneone
(@sevenoneone)
Active Member Registered
Joined: 4 months ago
Posts: 9
 

It works!!!!! YES! Thank you @simonjanssen and @savethehuman5

(Chameleon has "Disable Legacy Touch Behaviour" unchecked, and Panda is installed and running)

So happy! I'm really loving this software!


ReplyQuote
Simon Janssen
(@simonjanssen)
New Member Registered
Joined: 4 months ago
Posts: 4
Topic starter  

@sevenoneone Yes, that's the working config for me too. Glad you could sort it out 👍 


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 3 years ago
Posts: 662
 

Ok, great news!! 🙂
Just remember you have to choose one of the behaviour, legacy touch or non legacy touch, but no way to use both at same time, is a limitation of windows.
In simple words, touchdevices  can send mouse events or not send mouse events.

Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


ReplyQuote