Sensitivities don't...
 
Notifications
Clear all

[Solved] Sensitivities don't work in the midi mode

15 Posts
2 Users
0 Likes
196 Views
 Alex
(@alex1231)
Active Member
Joined: 1 year ago
Posts: 7
Topic starter  

Dear   SaveTheHuman5. I am trying to use Elephant to enable my dial to control simple automation with Studio One and Kontakt player. I prefer to use Midi mode as it doesn't seem to glitch and it works, the only issue that makes it useless is the fact that it takes 7 complete revolutions of the wheel to go from 1 to 127. I've tried changing sensitivities but it doesn't seem to work. The increment/decrement seems to stay at around 0.0079 per step. Is there anything I am missing to make sensitivities work in Midi mode? Anything I can do to fix this? Many thanks in advance for your help.


   
Quote
SaveTheHuman5
(@savethehuman5)
Noble Member Admin
Joined: 5 years ago
Posts: 942
 

Hello Alex!
Using MIDI monitor you can check MIDI sent by Elephant and you can check ELEPHANT not require 7 turns to reach 0 to 127, for sue just a little more of a 1/4 of rotation and you can reach 127 form 0 or o form 127.

Here a free MIDI monitor you can use for test purposes.
http://www.midiox.com/

Select in OPTION menu, MIDI DEVICES and then choose as a input midi device ELEPHANT.

This post was modified 3 months ago by SaveTheHuman5

About: https://savethehuman5.com/about/
Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


   
ReplyQuote
SaveTheHuman5
(@savethehuman5)
Noble Member Admin
Joined: 5 years ago
Posts: 942
 

Some users report a incorrect or erratic work of the dial with some USB dongles, maybe is related.
I cant confirm that in your case, but maybe is related too.
Sensitivity can use decimal. Bur i wont see anybody need at this moment, but can use, in a future update i make the textbox bigger in order can host decimal iin proper way.
Anyway test first with default value of 1 with MIDI OX monitor.

This post was modified 3 months ago by SaveTheHuman5

About: https://savethehuman5.com/about/
Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


   
ReplyQuote
 Alex
(@alex1231)
Active Member
Joined: 1 year ago
Posts: 7
Topic starter  

@savethehuman5 

This is one tick in studio one.

image

In Kontakt 1 tick is incrementing by 1 with each tick, each vibration. 

image

Adjusting Sensitivities doesn't seem to affect the speed/increment.  One tick is not 1 degree of rotation, its a distance between each vibration of the dial, not sure what this is in degrees, probably at least 5 degrees.

Please note that the sensitivities do work in nonmidi mode. How can I get it to work in MIDI mode as expected pls ?

This post was modified 3 months ago by Alex

   
ReplyQuote
SaveTheHuman5
(@savethehuman5)
Noble Member Admin
Joined: 5 years ago
Posts: 942
 

Installing MIDI OX you can see no need  "7 complete revolutions of the wheel to go from 1 to 127" (what for sure is 0 to 127 not 1 to 127)
Maybe I can install later this month studio one demo, and try to check what happens. Right now at this moment is impossible for me go deep in this.
Can you try to map encoder mode instead 0 to 127?.......... If is supported by the software you use of course.

This post was modified 3 months ago 4 times by SaveTheHuman5

About: https://savethehuman5.com/about/
Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


   
ReplyQuote
 Alex
(@alex1231)
Active Member
Joined: 1 year ago
Posts: 7
Topic starter  

@savethehuman5 it just seems to work only in the normal mode, when i switch to midi only, it doesn't respect the sensitivities. Kontakt player stand alone is also working in the same way. Encoder mode just gives me 1 or 127.


   
ReplyQuote
SaveTheHuman5
(@savethehuman5)
Noble Member Admin
Joined: 5 years ago
Posts: 942
 

Try enter in sensitivity 0.1 and check if you see a change in how respond.
For sure, the box not allow more than one character, I can fix that later, just check if you see change in how respond.

This post was modified 3 months ago 3 times by SaveTheHuman5

About: https://savethehuman5.com/about/
Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


   
ReplyQuote
 Alex
(@alex1231)
Active Member
Joined: 1 year ago
Posts: 7
Topic starter  

@savethehuman5 I've tried and it doesn't work. it only works in any non-midi mode where I select the control and then use the dial. for now, I've set-up my throttle quadrant that I use for the flight simulator as a midi controller and it works well as a midi controller but Would be nice to be able to use the dial.


   
ReplyQuote
SaveTheHuman5
(@savethehuman5)
Noble Member Admin
Joined: 5 years ago
Posts: 942
 

OK, no idea why not work for you, I test in Reaper, Ableton, Bitwig, Traktor an sensitivity works ok.
You have to post a complete guide and show hw your setup all, in order in some moment I try to reproduce the same config.
I cant fix a problem I cant reproduce.

About: https://savethehuman5.com/about/
Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


   
ReplyQuote
 Alex
(@alex1231)
Active Member
Joined: 1 year ago
Posts: 7
Topic starter  

@savethehuman5  I've checked with reaper and the same problem. I've tried various sensitivity settings but it doesn't change anything, it takes about 7 complete revolutions to go from 1 to 127. Here are the screenshots of my settings:

image
image

   
ReplyQuote
SaveTheHuman5
(@savethehuman5)
Noble Member Admin
Joined: 5 years ago
Posts: 942
 

OK here is the problem.
You need assign hotkeys to all mid buttons you plan to use.
When you fire the midi button form a hotkey, sensitivity change.
Is how works.
Check and confirm now your problem is solved.

About: https://savethehuman5.com/about/
Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


   
ReplyQuote
 Alex
(@alex1231)
Active Member
Joined: 1 year ago
Posts: 7
Topic starter  

@savethehuman5 Yes, now it works. Thank you very much. Didn't realize it's mandatory to add these shortcuts.


   
ReplyQuote
SaveTheHuman5
(@savethehuman5)
Noble Member Admin
Joined: 5 years ago
Posts: 942
 

The important thing here is working now for you!!!


GIF

About: https://savethehuman5.com/about/
Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


   
ReplyQuote
 Alex
(@alex1231)
Active Member
Joined: 1 year ago
Posts: 7
Topic starter  

@savethehuman5 Indeed. Would it be possible to make the change sufficient by only using Dial selector so it respects the sensitivities too without the need to reach out to keyboard ?


   
ReplyQuote
SaveTheHuman5
(@savethehuman5)
Noble Member Admin
Joined: 5 years ago
Posts: 942
 

Hi Again Alex.
Sorry, not possible at this moment. Maybe in the near future if more users request the same feature.

About: https://savethehuman5.com/about/
Youtube: https://www.youtube.com/SaveTheHuman5
Facebook: https://www.facebook.com/SaveTheHuman5


   
ReplyQuote
Share: